Difference between revisions of "ATI Force Torque Sensors"

From Healthcare Robotics Wiki
Jump to: navigation, search
(Models Used)
Line 1: Line 1:
 
== Models Used ==
 
== Models Used ==
* Mekabot: [http://www.ati-ia.com/products/ft/ft_models.aspx?id=Mini40 ATI Mini40] - with the SI-80-4 calibration.
+
* Cody: [http://www.ati-ia.com/products/ft/ft_models.aspx?id=Mini40 ATI Mini40] - with the SI-80-4 calibration.
 
* El-E: [http://www.ati-ia.com/products/ft/ft_models.aspx?id=Nano25 ATI Nano25] - with the SI-125-3 calibration.
 
* El-E: [http://www.ati-ia.com/products/ft/ft_models.aspx?id=Nano25 ATI Nano25] - with the SI-125-3 calibration.
  

Revision as of 08:48, 23 June 2010

Models Used

  • Cody: ATI Mini40 - with the SI-80-4 calibration.
  • El-E: ATI Nano25 - with the SI-125-3 calibration.

ATI FT Commands Manual

Changing the Baudrate with Minicom

Our driver for the ATI force torque sensors needs to know the baudrates of the controller boxes. To set the controller boxes' baudrates to the desired settings, we use minicom in Ubuntu Linux. Below are the steps needed to do so:

  • Install and launch minicom with:
 sudo apt-get install minicom
 minicom
  • Change the serial communication settings by typing Ctr-A Z, o, "Serial port setup", set
    • "Serial Device"
    • Hardware flow control to off
    • Software flow control to off
    • the expected default baudrate. New ATI controller boxes have a baudrate of 9600. If you don't know what the baudrate is, guess.
  • Select "Save setup as dfl", then exit minicom and start it again.
  • Now you should see a prompt:
 >
  • Try typing 'CB'. You should now see your current baudrate printed out:
 Baud Rate = 115200
  • If you see garbage characters then you are probably connected using an incorrect baudrate.
  • If all is well, set your desired baudrate with 'CB <YOUR_BAUDRATE>':
 CB 19200
  • Change your minicom default settings to connect with this new baudrate, then restart minicom.
  • After restarting, you should have a command prompt similar to before. Try executing 'CB' again to make sure that your settings are still correct. Then save your settings to the controller boxes' memory by executing:
 RS
  • If you want to confirm, then power cycle your controller boxes and make sure that you can still connect with the new baudrate.
  • Refer to the command manual for more information ( ATI FT Commands Manual)